Gentoo Logo

LibRaw, libkdcraw: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201309-09 / libraw
Release Date September 15, 2013
Latest Revision September 15, 2013: 1
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
media-libs/libraw < 0.15.4 >= 0.15.4 All supported architectures
kde-base/libkdcraw < 4.10.5-r1 >= 4.10.5-r1 All supported architectures

Related bugreports: #471694, #482926

Synopsis

Multiple vulnerabilities have been found in LibRaw and libkdcraw, the worst of which may lead to arbitrary code execution.

2.  Impact Information

Background

LibRaw is a library for reading RAW files obtained from digital photo cameras. libkdcraw is a wrapper for LibRaw within KDE.

Description

Multiple vulnerabilities have been discovered in LibRaw and libkdcraw. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could entice a user to open a specially crafted file, possibly resulting in arbitrary code execution or Denial of Service.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All LibRaw users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=media-libs/libraw-0.15.4"

All libkdcraw users should upgrade to the latest version:

Code Listing 3.2: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=kde-base/libkdcraw-4.10.5-r1"

4.  References



Print

Page updated September 15, 2013

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.