Gentoo Logo

nginx: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201310-04 / nginx
Release Date October 06, 2013
Latest Revision October 06, 2013: 1
Impact normal
Exploitable local, remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-servers/nginx < 1.4.1-r2 >= 1.4.1-r2 All supported architectures

Related bugreports: #458726, #468870

Synopsis

Multiple vulnerabilities have been found in nginx, the worst of which may allow execution of arbitrary code.

2.  Impact Information

Background

nginx is a robust, small, and high performance HTTP and reverse proxy server.

Description

Multiple vulnerabilities have been discovered in nginx. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could send a specially crafted request, possibly resulting in execution of arbitrary code with the privileges of the process, or a Denial of Service condition. Furthermore, a context-dependent attacker may be able to obtain sensitive information.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All nginx users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=www-servers/nginx-1.4.1-r2"

4.  References



Print

Page updated October 06, 2013

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.