Gentoo Logo

GnuTLS: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201310-18 / gnutls
Release Date October 28, 2013
Latest Revision October 28, 2013: 1
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-libs/gnutls < 2.12.23-r1 >= 2.12.23-r1 All supported architectures

Related bugreports: #455560, #471788

Synopsis

Multiple vulnerabilities have been discovered in GnuTLS, the worst of which could lead to Denial of Service.

2.  Impact Information

Background

GnuTLS is an Open Source implementation of the TLS 1.2 and SSL 3.0 protocols.

Description

Multiple vulnerabilities have been discovered in GnuTLS. Please review the CVE identifiers and Lucky Thirteen research paper referenced below for details.

Impact

A remote attacker could sent a specially crafted packet to cause a Denial of Service condition. Additionally, a remote attacker could perform man-in-the-middle attacks to recover plaintext data.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All GnuTLS users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-libs/gnutls-2.12.23-r1"

4.  References



Print

Page updated October 28, 2013

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.