Gentoo Logo

MediaWiki: Multiple vulnerabilities


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201310-21 / mediawiki
Release Date October 28, 2013
Latest Revision October 28, 2013: 1
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-apps/mediawiki < 1.21.2 >= 1.21.2, revision >= 1.20.7, revision >= 1.19.8 All supported architectures

Related bugreports: #460352, #466124, #468110, #471140, #483594


Multiple vulnerabilities have been found in MediaWiki, the worst of which could lead to Denial of Service.

2.  Impact Information


The MediaWiki wiki web application as used on


Multiple vulnerabilities have been discovered in MediaWiki. Please review the CVE identifiers referenced below for details.


A remote attacker may be able to execute arbitrary code, perform man-in-the-middle attacks, obtain sensitive information or perform cross-site scripting attacks.

3.  Resolution Information


There is no known workaround at this time.


All MediaWiki 1.21.x users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=www-apps/mediawiki-1.21.2"

All MediaWiki 1.20.x users should upgrade to the latest version:

Code Listing 3.2: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=www-apps/mediawiki-1.20.7"

All MediaWiki 1.19.x users should upgrade to the latest version:

Code Listing 3.3: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=www-apps/mediawiki-1.19.8"

4.  References


Page updated October 28, 2013

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.