Gentoo Logo

OpenSSL: Multiple Vulnerabilities


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201312-03 / OpenSSL
Release Date December 03, 2013
Latest Revision December 03, 2013: 2
Impact low
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-libs/openssl < 1.0.0j, < 0.9.8y revision >= 1.0.0j, revision >= 0.9.8y All supported architectures

Related bugreports: #369753, #406199, #412643, #415435, #455592


Multiple vulnerabilities have been found in OpenSSL allowing remote attackers to determine private keys or cause a Denial of Service.

2.  Impact Information


OpenSSL is an Open Source toolkit implementing the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1) as well as a general purpose cryptography library.


Multiple vulnerabilities have been discovered in OpenSSL. Please review the CVE identifiers referenced below for details.


Remote attackers can determine private keys, decrypt data, cause a Denial of Service or possibly have other unspecified impact.

3.  Resolution Information


There is no known workaround at this time.


All OpenSSL 1.0.x users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-libs/openssl-1.0.0j"

All OpenSSL 0.9.8 users should upgrade to the latest version:

Code Listing 3.2: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-libs/openssl-0.9.8y"

4.  References


Page updated December 03, 2013

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.