Gentoo Logo

Wireshark: Multiple vulnerabilities


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201312-13 / wireshark
Release Date December 16, 2013
Latest Revision December 16, 2013: 1
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-analyzer/wireshark < 1.10.3 >= 1.10.3, revision >= 1.8.11 All supported architectures

Related bugreports: #484582, #490434


Multiple vulnerabilities have been found in Wireshark, allowing remote attackers to execute arbitrary code or cause Denial of Service.

2.  Impact Information


Wireshark is a versatile network protocol analyzer.


Multiple vulnerabilities have been discovered in Wireshark. Please review the CVE identifiers referenced below for details.


A remote attacker could possibly execute arbitrary code with the privileges of the process or cause a Denial of Service condition.

3.  Resolution Information


There is no known workaround at this time.


All Wireshark 1.10 users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-analyzer/wireshark-1.10.3"

All Wireshark 1.8 users should upgrade to the latest version:

Code Listing 3.2: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-analyzer/wireshark-1.8.11"

4.  References


Page updated December 16, 2013

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.