Gentoo Logo

cURL: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201401-14 / curl
Release Date January 20, 2014
Latest Revision January 20, 2014: 1
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-misc/curl < 7.34.0-r1 >= 7.34.0-r1 All supported architectures

Related bugreports: #456074, #465678, #474354, #492688, #497092

Synopsis

Multiple vulnerabilities have been found in cURL, allowing attackers to execute arbitrary code or cause Denial of Service.

2.  Impact Information

Background

cURL is a command line tool for transferring files with URL syntax, supporting numerous protocols.

Description

Multiple vulnerabilities have been discovered in cURL. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could entice a user or automated process to connect to a malicious server using cURL, possibly resulting in the remote execution of arbitrary code or a Denial of Service condition.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All cURL users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-misc/curl-7.34.0-r1"

4.  References



Print

Page updated January 20, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.