Gentoo Logo

Asterisk: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201401-15 / asterisk
Release Date January 21, 2014
Latest Revision January 21, 2014: 1
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-misc/asterisk < 11.7.0 >= 11.7.0, revision >= 1.8.25.0 All supported architectures

Related bugreports: #449828, #463622, #482776, #494630

Synopsis

Multiple vulnerabilities have been found in Asterisk, the worst of which may allow execution of arbitrary code.

2.  Impact Information

Background

Asterisk is an open source telephony engine and toolkit.

Description

Multiple vulnerabilities have been discovered in Asterisk. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could execute arbitrary code with the privileges of the process, cause a Denial of Service condition, or obtain sensitive information.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Asterisk 11.* users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-misc/asterisk-11.7.0"

All Asterisk 1.8.* users should upgrade to the latest version:

Code Listing 3.2: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-misc/asterisk-1.8.25.0"

4.  References



Print

Page updated January 21, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.