Gentoo Logo

Roundcube: Arbitrary code execution


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201402-15 / roundcube
Release Date February 11, 2014
Latest Revision February 11, 2014: 1
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
mail-client/roundcube < 0.9.5 >= 0.9.5, revision >= 0.8.7 All supported architectures

Related bugreports: #488954


A vulnerability in Roundcube could result in arbitrary code execution, SQL injection, or reading of arbitrary files.

2.  Impact Information


Roundcube is a browser-based multilingual IMAP client with an application-like user interface.


A vulnerability in steps/utils/ allows remote attackers to use the _session parameter to change configuration settings.


A remote attacker could possibly execute arbitrary code with the privileges of the process, inject SQL code, or read arbitrary files.

3.  Resolution Information


There is no known workaround at this time.


All Roundcube 0.9 users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=mail-client/roundcube-0.9.5"

All Roundcube 0.8 users should upgrade to the latest version:

Code Listing 3.2: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=mail-client/roundcube-0.8.7"

4.  References


Page updated February 11, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.