Gentoo Logo

file: Denial of Service

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201403-03 / file
Release Date March 13, 2014
Latest Revision March 13, 2014: 1
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
sys-apps/file < 5.17 >= 5.17 All supported architectures

Related bugreports: #501574

Synopsis

A vulnerability in file could result in Denial of Service.

2.  Impact Information

Background

file is a utility that guesses a file format by scanning binary data for patterns.

Description

A flaw was found in the way the file utility determines the type of a file.

Impact

A remote attacker could entice a user to open a specially crafted file, possibly resulting in a Denial of Service condition.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All file users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=sys-apps/file-5.17"

4.  References



Print

Page updated March 13, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.