Gentoo Logo

GNU Emacs: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201403-05 / emacs
Release Date March 20, 2014
Latest Revision March 20, 2014: 1
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
app-editors/emacs < 24.1-r1 >= 24.1-r1, revision >= 23.4-r4, < 23.2 All supported architectures

Related bugreports: #398239, #431178

Synopsis

Two vulnerabilities have been found in GNU Emacs, possibly leading to user-assisted execution of arbitrary code.

2.  Impact Information

Background

GNU Emacs is a highly extensible and customizable text editor.

Description

Multiple vulnerabilities have been discovered in GNU Emacs:

  • When ‘global-ede-mode’ is enabled, EDE in Emacs automatically loads a Project.ede file from the project directory (CVE-2012-0035).
  • When ‘enable-local-variables’’ is set to ‘:safe’, Emacs automatically processes eval forms (CVE-2012-3479).

Impact

A remote attacker could entice a user to open a specially crafted file, possibly resulting in execution of arbitrary code with the privileges of the process or a Denial of Service condition.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All GNU Emacs 24.x users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=app-editors/emacs-24.1-r1"

All GNU Emacs 23.x users should upgrade to the latest version:

Code Listing 3.2: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=app-editors/emacs-23.4-r4"

4.  References



Print

Page updated March 20, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.