Gentoo Logo

Mesa: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201404-06 / mesa
Release Date April 08, 2014
Latest Revision April 08, 2014: 1
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
media-libs/mesa < 9.1.4 >= 9.1.4 All supported architectures

Related bugreports: #432400, #445916, #472280

Synopsis

Multiple vulnerabilities in Mesa could result in execution of arbitrary code or Denial of Service.

2.  Impact Information

Background

Mesa is an OpenGL-like graphic library for Linux.

Description

Multiple vulnerabilities have been discovered in Mesa. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could possibly execute arbitrary code with the privileges of the process, or cause a Denial of Service condition.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Mesa users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=media-libs/mesa-9.1.4"

4.  References



Print

Page updated April 08, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.