Gentoo Logo

libSRTP: Denial of Service

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201405-02 / libsrtp
Release Date May 03, 2014
Latest Revision May 03, 2014: 1
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-libs/libsrtp < 1.4.4_p20121108-r1 >= 1.4.4_p20121108-r1 All supported architectures

Related bugreports: #472302

Synopsis

A vulnerability in libSRTP can result in a Denial of Service condition.

2.  Impact Information

Background

libSRTP is an Open-source implementation of the Secure Real-time Transport Protocol.

Description

A flaw was found in how the crypto_policy_set_from_profile_for_rtp() function applies cryptographic profiles to an srtp_policy in libSRTP.

Impact

A remote attacker could exploit this vulnerability to crash an application linked against libSRTP, resulting in Denial of Service.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All libSRTP users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose
  ">=net-libs/libsrtp-1.4.4_p20121108-r1"

4.  References



Print

Page updated May 03, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.