Gentoo Logo

WeeChat: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201405-03 / weechat
Release Date May 03, 2014
Latest Revision May 03, 2014: 1
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-irc/weechat < 0.3.9.2 >= 0.3.9.2 All supported architectures

Related bugreports: #442600

Synopsis

Two vulnerabilities have been found in WeeChat, the worst of which may allow execution of arbitrary code.

2.  Impact Information

Background

Wee Enhanced Environment for Chat (WeeChat) is a light and extensible console IRC client.

Description

Two vulnerabilities have been discovered in WeeChat:

  • The hook_process() function does not properly handle shell expansions (CVE-2012-5534).
  • WeeChat does not properly decode colors which could cause a heap-based buffer overflow (CVE-2012-5854).

Impact

A remote attacker could entice a user to open a specially crafted script or send messages with specially crafted colors, possibly resulting in execution of arbitrary code with the privileges of the process, or a Denial of Service condition.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All WeeChat users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-irc/weechat-0.3.9.2"

4.  References



Print

Page updated May 03, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.