Gentoo Logo

Rack: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201405-10 / rack
Release Date May 17, 2014
Latest Revision May 17, 2014: 1
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-ruby/rack < 1.4.5 >= 1.4.5, revision >= 1.3.10, revision >= 1.2.8, revision >= 1.1.6 All supported architectures

Related bugreports: #451620, #456176

Synopsis

Multiple vulnerabilities have been found in Rack, the worst of which allow execution of arbitrary code.

2.  Impact Information

Background

Rack is a modular Ruby web server interface.

Description

Multiple vulnerabilities have been discovered in Rack. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could possibly execute arbitrary code with the privileges of the process, cause a Denial of Service condition, or obtain sensitive information.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Rack 1.4 users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-ruby/rack-1.4.5"

All Rack 1.3 users should upgrade to the latest version:

Code Listing 3.2: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-ruby/rack-1.3.10"

All Rack 1.2 users should upgrade to the latest version:

Code Listing 3.3: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-ruby/rack-1.2.8"

All Rack 1.1 users should upgrade to the latest version:

Code Listing 3.4: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-ruby/rack-1.1.6"

4.  References



Print

Page updated May 17, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.