Gentoo Logo

lib3ds: User-assisted execution of arbitrary code

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201405-23 / lib3ds
Release Date May 18, 2014
Latest Revision December 10, 2014: 2
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
media-libs/lib3ds < 2.0.0_rc1 >= 2.0.0_rc1, revision >= 1.3.0-r1 All supported architectures

Related bugreports: #308033, #519936

Synopsis

A vulnerability in lib3ds might allow a remote attacker to execute arbitrary code.

2.  Impact Information

Background

lib3ds is a library for managing 3D-Studio Release 3 and 4 .3DS files.

Description

An array index error has been discovered in lib3ds.

Impact

A remote attacker could entice a user to open a specially crafted 3DS file using an application linked against lib3ds, possibly resulting in execution of arbitrary code with the privileges of the process or a Denial of Service condition.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All lib3ds 2.0 users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=media-libs/lib3ds-2.0.0_rc1"

All lib3ds 1.3 users should upgrade to the latest version:

Code Listing 3.2: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=media-libs/lib3ds-1.3.0-r1"

Packages which depend on this library may need to be recompiled. Tools such as revdep-rebuild may assist in identifying some of these packages.

4.  References



Print

Page updated May 18, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.