Gentoo Logo

LibYAML: Arbitrary code execution

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201405-27 / libyaml
Release Date May 23, 2014
Latest Revision May 23, 2014: 1
Impact normal
Exploitable local, remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-libs/libyaml < 0.1.6 >= 0.1.6 All supported architectures

Related bugreports: #505948

Synopsis

A vulnerability in LibYAML could allow an attacker to execute arbitrary code or cause a Denial of Service condition.

2.  Impact Information

Background

LibYAML is a YAML 1.1 parser and emitter written in C.

Description

The yaml_parser_scan_uri_escapes() function does not properly expand strings passed as input, which can result in a heap-based buffer overflow.

Impact

An attacker could provide a specially-crafted YAML document, which, when parsed by LibYAML, could result in arbitrary code execution or cause the application to crash.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All LibYAML users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-libs/libyaml-0.1.6"

Packages which depend on this library may need to be recompiled. Tools such as revdep-rebuild may assist in identifying these packages.

4.  References



Print

Page updated May 23, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.