Gentoo Logo

D-Bus, GLib: Privilege escalation

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201406-01 / dbus
Release Date June 01, 2014
Latest Revision June 01, 2014: 1
Impact high
Exploitable local
Package Vulnerable versions Unaffected versions Architecture(s)
sys-apps/dbus < 1.6.8 >= 1.6.8 All supported architectures
dev-libs/glib < 2.32.4-r1 >= 2.32.4-r1 All supported architectures

Related bugreports: #436028

Synopsis

A vulnerability has been found in D-Bus which allows local attackers to gain escalated privileges.

2.  Impact Information

Background

D-Bus is a daemon providing a framework for applications to communicate with one another. GLib is a library providing a number of GNOME’s core objects and functions.

Description

When libdbus is used in a setuid program, a user can gain escalated privileges by leveraging the DBUS_SYSTEM_BUS_ADDRESS variable. GLib can be used in a setuid context with D-Bus, and so can trigger this vulnerability. Please review the CVE identifier below for more details.

Impact

A local attacker could gain escalated privileges and execute arbitrary code.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All D-Bus users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=sys-apps/dbus-1.6.8"

All GLib users should upgrade to the latest version:

Code Listing 3.2: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-libs/glib-2.32.4-r1"

4.  References



Print

Page updated June 01, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.