Gentoo Logo

SystemTap: Denial of Service

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201406-04 / systemtap
Release Date June 05, 2014
Latest Revision June 05, 2014: 1
Impact normal
Exploitable local
Package Vulnerable versions Unaffected versions Architecture(s)
dev-util/systemtap < 2.0 >= 2.0 All supported architectures

Related bugreports: #405345

Synopsis

A vulnerability in SystemTap could allow a local attacker to create a Denial of Service condition.

2.  Impact Information

Background

SystemTap is a kernel profiling and instrumentation tool.

Description

SystemTap does not properly handle DWARF expressions when unwinding the stack.

Impact

A local attacker with SystemTap permissions could trigger a kernel panic, causing a Denial of Service condition.

3.  Resolution Information

Workaround

Disabling unprivileged mode is a temporary workaround for this vulnerability.

Resolution

All SystemTap users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-util/systemtap-2.0"

4.  References



Print

Page updated June 05, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.