Gentoo Logo

libXfont: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201406-11 / libXfont
Release Date June 14, 2014
Latest Revision June 14, 2014: 1
Impact high
Exploitable local, remote
Package Vulnerable versions Unaffected versions Architecture(s)
x11-libs/libXfont < 1.4.8 >= 1.4.8 All supported architectures

Related bugreports: #510250

Synopsis

Multiple vulnerabilities have been found in libXfont, the worst of which allow for local privilege escalation.

2.  Impact Information

Background

libXfont is an X11 font rasterisation library.

Description

Multiple vulnerabilities have been discovered in libXfont. Please review the CVE identifiers referenced below for details.

Impact

A context-dependent attacker could use a specially crafted file to gain privileges, cause a Denial of Service condition or possibly execute arbitrary code with the privileges of the process.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All libXfont users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=x11-libs/libXfont-1.4.8"

4.  References



Print

Page updated June 14, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.