Gentoo Logo

KDirStat: Arbitrary command execution

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201406-15 / kdirstat
Release Date June 15, 2014
Latest Revision June 15, 2014: 1
Impact normal
Exploitable local
Package Vulnerable versions Unaffected versions Architecture(s)
kde-misc/kdirstat < 2.7.5 >= 2.7.5 All supported architectures

Related bugreports: #504994

Synopsis

A vulnerability in KDirStat could allow local attackers to execute arbitrary shell commands.

2.  Impact Information

Background

KDirStat is a graphical disk usage utility for KDE.

Description

Missing escape of executable shell command in KDirStat can be used to insert malicious shell commands.

Impact

A local attacker could possibly execute arbitrary shell command with the privileges of the process.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All KDirStat users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=kde-misc/kdirstat-2.7.5"

4.  References



Print

Page updated June 15, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.