Gentoo Logo

cups-filters: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201406-16 / cups-filters
Release Date June 16, 2014
Latest Revision June 16, 2014: 1
Impact normal
Exploitable local, remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-print/cups-filters < 1.0.53 >= 1.0.53 All supported architectures

Related bugreports: #504474, #506518, #508844

Synopsis

Multiple vulnerabilities have been found in cups-filters, worst of which allows remote attackers to execute arbitrary code.

2.  Impact Information

Background

cups-filters is an OpenPrinting CUPS Filters.

Description

Multiple vulnerabilities have been discovered in cups-filters. Please review the CVE identifiers referenced below for more details about the vulnerabilities.

Impact

A remote attacker(s) could possibly execute arbitrary code utilizing multiple attack vectors, or a local attacker could gain escalated privileges via a specially crafted shared library.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All cups-filters users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-print/cups-filters-1.0.53"

4.  References



Print

Page updated June 16, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.