Gentoo Logo

Network Audio System: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201406-22 / nas
Release Date June 25, 2014
Latest Revision June 25, 2014: 1
Impact normal
Exploitable local, remote
Package Vulnerable versions Unaffected versions Architecture(s)
media-libs/nas < 1.9.4 >= 1.9.4 All supported architectures

Related bugreports: #484480

Synopsis

Multiple vulnerabilities have been found in Network Audio System, the worst of which allows remote attackers to execute arbitrary code.

2.  Impact Information

Background

Network Audio System is a network transparent, client/server audio transport system.

Description

Multiple vulnerabilities have been discovered in Network Audio System. Please review the CVE identifiers referenced below for details.

Impact

A context-dependent attacker could possibly execute arbitrary code with the privileges of the process or cause a Denial of Service condition.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Network Audio System users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=media-libs/nas-1.9.4"

Packages which depend on this library may need to be recompiled. Tools such as revdep-rebuild may assist in identifying some of these packages.

4.  References



Print

Page updated June 25, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.