Gentoo Logo

DenyHosts: Denial of Service

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201406-23 / denyhost
Release Date June 25, 2014
Latest Revision June 25, 2014: 1
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
app-admin/denyhosts < 2.6-r9 >= 2.6-r9 All supported architectures

Related bugreports: #495130

Synopsis

A vulnerability in DenyHosts could allow a remote attacker to create a Denial of Service condition.

2.  Impact Information

Background

DenyHosts is a script intended to be run by Linux system administrators to help thwart SSH server attacks.

Description

DenyHosts does not properly define the regular expressions used when parsing SSH authentication logs.

Impact

A remote attacker could possibly cause a Denial of Service condition via a crafted login name.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All DenyHost users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=app-admin/denyhosts-2.6-r9"

4.  References



Print

Page updated June 25, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.