Gentoo Logo

Asterisk: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201406-25 / asterisk
Release Date June 25, 2014
Latest Revision June 25, 2014: 2
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-misc/asterisk < 11.10.2 >= 11.10.2, revision >= 1.8.28.2 All supported architectures

Related bugreports: #513102

Synopsis

Multiple vulnerabilities have been discovered in Asterisk, the worst of which could allow privileged users to execute arbitrary system shell commands.

2.  Impact Information

Background

Asterisk is an open source telephony engine and toolkit.

Description

Multiple vulnerabilities have been discovered in Asterisk. Please review the CVE identifiers below for details.

Impact

A remote attacker that gains access to a privileged Asterisk account can execute arbitrary system shell commands. Furthermore an unprivileged remote attacker could cause a Denial of Service condition.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Asterisk 11 users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-misc/asterisk-11.10.2"

All Asterisk 1.8 users should upgrade to the latest version:

Code Listing 3.2: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-misc/asterisk-1.8.28.2"

4.  References



Print

Page updated June 25, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.