Gentoo Logo

Django: Multiple vulnerabilities


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201406-26 / django
Release Date June 26, 2014
Latest Revision December 03, 2014: 2
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-python/django < 1.6.5 >= 1.6.5, revision >= 1.5.8, revision >= 1.4.13, revision >= 1.5.10, revision >= 1.4.15 All supported architectures

Related bugreports: #508514, #510382


Multiple vulnerabilities have been found Django, the worst of which may allow a remote attacker to execute code.

2.  Impact Information


Django is a Python-based web framework.


Multiple vulnerabilities have been discovered in Django. Please review the CVE identifiers referenced below for details.


A remote attacker could execute code with the privileges of the process, modify SQL queries, or disclose sensitive information.

3.  Resolution Information


There is no known workaround at this time.


All Django 1.6 users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-python/django-1.6.5"

All Django 1.5 users should upgrade to the latest version:

Code Listing 3.2: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-python/django-1.5.8"

All Django 1.4 users should upgrade to the latest version:

Code Listing 3.3: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-python/django-1.4.13"

4.  References


Page updated June 26, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.