Gentoo Logo

polkit, Spice-Gtk, systemd, HPLIP, libvirt: Privilege escalation

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201406-27 / polkit spice-gtk systemd hplip libvirt
Release Date June 26, 2014
Latest Revision June 26, 2014: 1
Impact high
Exploitable local
Package Vulnerable versions Unaffected versions Architecture(s)
net-print/hplip < 3.14.1 >= 3.14.1 All supported architectures
net-misc/spice-gtk < 0.21 >= 0.21 All supported architectures
sys-apps/systemd < 204-r1 >= 204-r1 All supported architectures
app-emulation/libvirt < 1.1.2-r3 >= 1.1.2-r3 All supported architectures
sys-auth/polkit < 0.112 >= 0.112 All supported architectures

Related bugreports: #484486, #484488, #485420, #485546, #485904

Synopsis

A race condition in polkit could allow a local attacker to gain escalated privileges.

2.  Impact Information

Background

polkit is a toolkit for managing policies relating to unprivileged processes communicating with privileged processes.

Description

polkit has a race condition which potentially allows a process to change its UID/EUID via suid or pkexec before authentication is completed.

Impact

A local attacker could start a suid or pkexec process through a polkit-enabled application, which could result in privilege escalation or bypass of polkit restrictions.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All polkit users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=sys-auth/polkit-0.112"

All HPLIP users should upgrade to the latest version:

Code Listing 3.2: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-print/hplip-3.14.1"

All Spice-Gtk users should upgrade to the latest version:

Code Listing 3.3: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-misc/spice-gtk-0.21"

All systemd users should upgrade to the latest version:

Code Listing 3.4: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=sys-apps/systemd-204-r1"

All libvirt users should upgrade to the latest version:

Code Listing 3.5: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=app-emulation/libvirt-1.1.2-r3"

4.  References



Print

Page updated June 26, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.