Gentoo Logo

Wireshark: Multiple vulnerabilities


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201406-33 / wireshark
Release Date June 29, 2014
Latest Revision June 29, 2014: 1
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-analyzer/wireshark < 1.10.8 revision >= 1.8.15, >= 1.10.8 All supported architectures

Related bugreports: #503792, #507298, #508506, #513094


Multiple vulnerabilities have been found in Wireshark, the worst of which allows remote attackers to execute arbitrary code.

2.  Impact Information


Wireshark is a network protocol analyzer formerly known as ethereal.


Multiple vulnerabilities have been discovered in Wireshark. Please review the CVE identifiers referenced below for details.


A remote attacker can cause arbitrary code execution or a Denial of Service condition via a specially crafted packet.

3.  Resolution Information


There is no known workaround at this time.


All Wireshark 1.8.x users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-analyzer/wireshark-1.8.15"

All Wireshark 1.10.x users should upgrade to the latest version:

Code Listing 3.2: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-analyzer/wireshark-1.10.8"

4.  References


Page updated June 29, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.