Gentoo Logo

Openfire: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201406-35 / openfire
Release Date June 30, 2014
Latest Revision June 30, 2014: 1
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-im/openfire < 3.9.2-r1 >= 3.9.2-r1 All supported architectures

Related bugreports: #266129, #507242

Synopsis

Multiple vulnerabilities have been found in Openfire, the worst of which could lead to a Denial of Service condition.

2.  Impact Information

Background

Openfire is a real time collaboration (RTC) server.

Description

Multiple vulnerabilities have been discovered in Openfire. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could possibly cause a Denial of Service condition or bypass security restrictions.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Openfire users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-im/openfire-3.9.2-r1"

4.  References



Print

Page updated June 30, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.