Gentoo Logo

Xen: Multiple Vunlerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201407-03 / xen
Release Date July 16, 2014
Latest Revision July 16, 2014: 1
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
app-emulations/xen < 4.3.2-r4 >= 4.3.2-r4, revision >= 4.2.4-r4 All supported architectures
app-emulations/xen-tools < 4.3.2-r5 >= 4.3.2-r5, revision >= 4.2.4-r6 All supported architectures
app-emulations/xen-pvgrub < 4.3.2 revision >= 4.3.2, revision >= 4.2.4 All supported architectures

Related bugreports: #440768, #484478, #486354, #497082, #497084, #497086, #499054, #499124, #500528, #500530, #500536, #501080, #501906, #505714, #509054, #513824

Synopsis

Multiple vulnerabilities have been found in Xen, the worst of which could lead to arbitrary code execution.

2.  Impact Information

Background

Xen is a bare-metal hypervisor.

Description

Multiple vulnerabilities have been discovered in Xen. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker can utilize multiple vectors to execute arbitrary code, cause Denial of Service, or gain access to data on the host.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Xen 4.3 users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=app-emulations/xen-4.3.2-r2"

All Xen 4.2 users should upgrade to the latest version:

Code Listing 3.2: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=app-emulations/xen-4.2.4-r2"

All xen-tools 4.3 users should upgrade to the latest version:

Code Listing 3.3: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose
  ">=app-emulations/xen-tools-4.3.2-r2"

All xen-tools 4.2 users should upgrade to the latest version:

Code Listing 3.4: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose
  ">=app-emulations/xen-tools-4.2.4-r2"

All Xen PVGRUB 4.3 users should upgrade to the latest version:

Code Listing 3.5: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=app-emulations/xen-pvgrub-4.3.2"

All Xen PVGRUB 4.2 users should upgrade to the latest version:

Code Listing 3.6: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=app-emulations/xen-pvgrub-4.2.4"

4.  References



Print

Page updated July 16, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.