Gentoo Logo

GnuPG: Denial of Service

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201407-04 / GnuPG.
Release Date July 16, 2014
Latest Revision July 16, 2014: 1
Impact normal
Exploitable local, remote
Package Vulnerable versions Unaffected versions Architecture(s)
app-crypt/gnupg < 2.0.24 >= 2.0.24, revision >= 1.4.17, revision >= 1.4.18, revision >= 1.4.19, revision >= 1.4.20, revision >= 1.4.21 All supported architectures

Related bugreports: #514718

Synopsis

A vulnerability in GnuPG can lead to a Denial of Service condition.

2.  Impact Information

Background

The GNU Privacy Guard, GnuPG, is a free replacement for the PGP suite of cryptographic software.

Description

GnuPG does not properly handle a specially crated compressed packet resulting in an infinite loop.

Impact

A context-dependent attacker can cause a Denial of Service.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All GnuPG 2.0 users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=app-crypt/gnupg-2.0.24"

All GnuPG 1.4 users should upgrade to the latest version:

Code Listing 3.2: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=app-crypt/gnupg-1.4.17"

4.  References



Print

Page updated July 16, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.