Gentoo Logo

ModPlug XMMS Plugin: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 201408-07 / modplug
Release Date August 16, 2014
Latest Revision August 16, 2014: 1
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
media-libs/libmodplug < 0.8.8.5 >= 0.8.8.5 All supported architectures

Related bugreports: #480388

Synopsis

Multiple vulnerabilities have been found in ModPlug XMMS Plugin, worst of which allows remote attackers to execute arbitrary code.

2.  Impact Information

Background

ModPlug XMMS Plugin is a library for playing MOD-like music files

Description

Multiple vulnerabilities have been discovered in ModPlug XMMS Plugin. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could possibly execute arbitrary code with the privileges of the process, or cause a Denial of Service condition.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All ModPlug XMMS Plugin users should upgrade to the latest version:

Code Listing 3.1: Resolution

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=media-libs/libmodplug-0.8.8.5"

4.  References



Print

Page updated August 16, 2014

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.