xorg-x11-7.4 and xorg-server-1.5 kernel support

Title: xorg-x11-7.4 and xorg-server-1.5 kernel support
Author: Tobias Klausmann <klausman@gentoo.org>
Content-Type: text/plain
Posted: 2009-07-12
Revision: 1
News-Item-Format: 1.0
Display-If-Installed: x11-base/xorg-server
Display-If-Profile: default-linux/alpha
Display-If-Profile: default/linux/alpha

Recent versions of xorg's X11 require kernel support to access PCI and AGP
graphic cards. This support has only recently been added to the Linux kernel
(sys-kernel/vanilla-sources-2.6.30 and sys-kernel/gentoo-sources-2.6.29-r5).
Thus, you will need to run a recent enough kernel to use recent versions of X11
on an alpha. If you only start programs on your alpha, but the display is on
another machine, no upgrade is necessary.

Furthermore, not all graphics card drivers have been updated to work with the
newer X server API. One example is the glint driver used for Permedia cards. The
upstream developers have been informed about this, but no fixes are available
yet, please see https://bugs.freedesktop.org/show_bug.cgi?id=21546

For a general guide to upgrading to Xorg 1.5, see the Gentoo upgrade guide:
http://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-1.5-upgrade-guide.xml