Gentoo Logo

phpMyAdmin < 2.5.6-rc1: possible attack against export.php


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200402-05 / phpmyadmin
Release Date February 17, 2004
Latest Revision February 17, 2004: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-db/phpmyadmin <= 2.5.5_p1 >= 2.5.6_rc1 All supported architectures

Related bugreports: #40268


A vulnerability in phpMyAdmin which was not properly verifying user generated input could lead to a directory traversal attack.

2.  Impact Information


phpMyAdmin is a tool written in PHP intended to handle the administration of MySQL databased over the Web.


One component of the phpMyAdmin software package (export.php) does not properly verify input that is passed to it from a remote user. Since the input is used to include other files, it is possible to launch a directory traversal attack.


Private information could be gleaned from the remote server if an attacker uses a malformed URL such as[existing_file]

In this scenario, the script does not sanitize the "what" argument passed to it, allowing directory traversal attacks to take place, disclosing the contents of files if the file is readable as the web-server user.

3.  Resolution Information


The workaround is to either patch the export.php file using the referenced CVS patch or upgrade the software via Portage.


Users are encouraged to upgrade to phpMyAdmin-2.5.6_rc1:

Code Listing 3.1: Resolution

# emerge sync
# emerge -pv ">=dev-db/phpmyadmin-2.5.6_rc1"
# emerge ">=dev-db/phpmyadmin-2.5.6_rc1"
# emerge clean

4.  References


Page updated February 17, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.