Gentoo Logo

Updated kernel packages fix the AMD64 ptrace vulnerability

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200402-06 / Kernel
Release Date February 17, 2004
Latest Revision February 17, 2004: 01
Impact normal
Exploitable local
Package Vulnerable versions Unaffected versions Architecture(s)
sys-kernel/ck-sources < 2.6.2 >= 2.6.2 AMD64
sys-kernel/development-sources < 2.6.2 >= 2.6.2 AMD64
sys-kernel/gentoo-dev-sources < 2.6.2 >= 2.6.2 AMD64
sys-kernel/gentoo-sources < 2.4.22-r6 >= 2.4.22-r6 AMD64
sys-kernel/gentoo-test-sources < 2.6.2 >= 2.6.2-r1 AMD64
sys-kernel/gs-sources < 2.4.25_pre7-r1 >= 2.4.25_pre7-r1 AMD64
sys-kernel/vanilla-prepatch-sources < 2.4.25_rc3 >= 2.4.25_rc3 AMD64
sys-kernel/vanilla-sources < 2.4.24-r1 >= 2.4.24-r1 AMD64

Related bugreports: No related gentoo bugreports

Synopsis

A vulnerability has been discovered by in the ptrace emulation code for AMD64 platforms when eflags are processed, allowing a local user to obtain elevated priveleges.

2.  Impact Information

Description

A vulnerability has been discovered by Andi Kleen in the ptrace emulation code for AMD64 platforms when eflags are processed, allowing a local user to obtain elevated priveleges. The Common Vulnerabilities and Exposures project, http://cve.mitre.org, has assigned CAN-2004-0001 to this issue.

Impact

Only users of the AMD64 platform are affected: in this scenario, a user may be able to obtain elevated priveleges, including root access. However, no public exploit is known for the vulnerability at this time.

3.  Resolution Information

Workaround

There is no temporary workaround - a kernel upgrade is required. A list of unaffected kernels is provided along with this announcement.

Resolution

Users are encouraged to upgrade to the latest available sources for their system:

Code Listing 3.1: Resolution

# emerge sync
# emerge -pv your-favourite-sources
# emerge your-favourite-sources
# # Follow usual procedure for compiling and installing a kernel.
# # If you use genkernel, run genkernel as you would do normally.

Code Listing 3.2: Resolution

# # IF YOUR KERNEL IS MARKED as "remerge required!" THEN
# # YOU SHOULD UPDATE YOUR KERNEL EVEN IF PORTAGE
# # REPORTS THAT THE SAME VERSION IS INSTALLED.



Print

Page updated February 17, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.