Gentoo Logo

Multiple Security Vulnerabilities in Monit

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200403-14 / app-admin/monit
Release Date March 31, 2004
Latest Revision May 22, 2006: 02
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
app-admin/monit <= 4.1 >= 4.2 All supported architectures

Related bugreports: #43967

Synopsis

A denial of service and a buffer overflow vulnerability have been found in Monit.

2.  Impact Information

Background

Monit is a system administration utility that allows management and monitoring of processes, files, directories and devices on a Unix system.

Description

A denial of service may occur due to Monit not sanitizing remotely supplied HTTP parameters before passing them to memory allocation functions. This could allow an attacker to cause an unexpected condition that could lead to the Monit daemon crashing.

An overly long http request method may cause a buffer overflow due to Monit performing insufficient bounds checking when handling HTTP requests.

Impact

An attacker may crash the Monit daemon to create a denial of service condition or cause a buffer overflow that would allow arbitrary code to be executed with root privileges.

3.  Resolution Information

Workaround

A workaround is not currently known for this issue. All users are advised to upgrade to the latest version of the affected package.

Resolution

Monit users should upgrade to version 4.2 or later:

Code Listing 3.1: Resolution

# emerge sync

# emerge -pv ">=app-admin/monit-4.2"
# emerge ">=app-admin/monit-4.2"

4.  References



Print

Page updated March 31, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.