Gentoo Logo

XChat 2.0.x SOCKS5 Vulnerability

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200404-15 / xchat
Release Date April 19, 2004
Latest Revision May 22, 2006: 02
Impact low
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-irc/xchat < 2.0.8-r1 >= 2.0.8-r1 All supported architectures

Related bugreports: #46856

Synopsis

XChat is vulnerable to a stack overflow that may allow a remote attacker to run arbitrary code.

2.  Impact Information

Background

XChat is a multiplatform IRC client.

Description

The SOCKS 5 proxy code in XChat is vulnerable to a remote exploit. Users would have to be using XChat through a SOCKS 5 server, enable SOCKS 5 traversal which is disabled by default and also connect to an attacker's custom proxy server.

Impact

This vulnerability may allow an attacker to run arbitrary code within the context of the user ID of the XChat client.

3.  Resolution Information

Workaround

A workaround is not currently known for this issue. All users are advised to upgrade to the latest version of the affected package.

Resolution

All XChat users should upgrade to the latest stable version:

Code Listing 3.1: Resolution

# emerge sync

# emerge -pv ">=net-irc/xchat-2.0.8-r1"
# emerge ">=net-irc/xchat-2.0.8-r1"

Note that users of the gtk1 version of xchat (1.8.*) should upgrade to xchat-1.8.11-r1:

Code Listing 3.2: Resolution

# emerge sync

# emerge -pv "=net-irc/xchat-1.8.11-r1"
# emerge "=net-irc/xchat-1.8.11-r1"

4.  References



Print

Page updated April 19, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.