Gentoo Logo

Ethereal: Multiple security problems

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200406-01 / Ethereal
Release Date June 04, 2004
Latest Revision May 22, 2006: 02
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-analyzer/ethereal <= 0.10.3 >= 0.10.4 All supported architectures

Related bugreports: #51022

Synopsis

Multiple vulnerabilities including one buffer overflow exist in Ethereal, which may allow an attacker to run arbitrary code or crash the program.

2.  Impact Information

Background

Ethereal is a feature rich network protocol analyzer.

Description

There are multiple vulnerabilities in versions of Ethereal earlier than 0.10.4, including:

  • A buffer overflow in the MMSE dissector.
  • Under specific conditions a SIP packet could make Ethereal crash.
  • The AIM dissector could throw an assertion, causing Ethereal to crash.
  • The SPNEGO dissector could dereference a null pointer, causing a crash.

Impact

An attacker could use these vulnerabilities to crash Ethereal or even execute arbitrary code with the permissions of the user running Ethereal, which could be the root user.

3.  Resolution Information

Workaround

For a temporary workaround you can disable all affected protocol dissectors by selecting Analyze->Enabled Protocols... and deselecting them from the list. However, it is strongly recommended to upgrade to the latest stable release.

Resolution

All Ethereal users should upgrade to the latest stable version:

Code Listing 3.1: Resolution

# emerge sync

# emerge -pv ">=net-analyzer/ethereal-0.10.4"
# emerge ">=net-analyzer/ethereal-0.10.4"

4.  References



Print

Page updated June 04, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.