Gentoo Logo

libpng: Buffer overflow on row buffers


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200407-06 / libpng
Release Date July 08, 2004
Latest Revision July 08, 2004: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
media-libs/libpng <= 1.2.5-r6 >= 1.2.5-r7 All supported architectures

Related bugreports: #56307


libpng contains a buffer overflow vulnerability potentially allowing an attacker to perform a Denial of Service attack or even execute arbitrary code.

2.  Impact Information


libpng is a standard library used to process PNG (Portable Network Graphics) images. It is used by several other programs, including web browsers and potentially server processes.


Due to a wrong calculation of loop offset values, libpng contains a buffer overflow vulnerability on the row buffers. This vulnerability was initially patched in January 2003 but since it has been discovered that libpng contains the same vulnerability in two other places.


An attacker could exploit this vulnerability to cause programs linked against the library to crash or execute arbitrary code with the permissions of the user running the vulnerable program, which could be the root user.

3.  Resolution Information


There is no known workaround at this time. All users are encouraged to upgrade to the latest available version.


All libpng users should upgrade to the latest stable version:

Code Listing 3.1: Resolution

# emerge sync
# emerge -pv ">=media-libs/libpng-1.2.5-r7"
# emerge ">=media-libs/libpng-1.2.5-r7"

You should also run revdep-rebuild to rebuild any packages that depend on older versions of libpng :

Code Listing 3.2: Resolution

# revdep-rebuild

4.  References


Page updated July 08, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.