Gentoo Logo

libpng: Numerous vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200408-03 / libpng
Release Date August 05, 2004
Latest Revision August 05, 2004: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
media-libs/libpng <= 1.2.5-r7 >= 1.2.5-r8 All supported architectures

Related bugreports: #59424

Synopsis

libpng contains numerous vulnerabilities potentially allowing an attacker to perform a Denial of Service attack or even execute arbitrary code.

2.  Impact Information

Background

libpng is a standard library used to process PNG (Portable Network Graphics) images. It is used by several other programs, including web browsers and potentially server processes.

Description

libpng contains numerous vulnerabilities including null pointer dereference errors and boundary errors in various functions.

Impact

An attacker could exploit these vulnerabilities to cause programs linked against the library to crash or execute arbitrary code with the permissions of the user running the vulnerable program, which could be the root user.

3.  Resolution Information

Workaround

There is no known workaround at this time. All users are encouraged to upgrade to the latest available version.

Resolution

All libpng users should upgrade to the latest stable version:

Code Listing 3.1: Resolution

# emerge sync
# emerge -pv ">=media-libs/libpng-1.2.5-r8"
# emerge ">=media-libs/libpng-1.2.5-r8"

You should also run revdep-rebuild to rebuild any packages that depend on older versions of libpng :

Code Listing 3.2: Resolution

# revdep-rebuild

4.  References



Print

Page updated August 05, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.