Gentoo Logo

Horde-IMP: Input validation vulnerability for Internet Explorer users

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200408-07 / horde-imp
Release Date August 10, 2004
Latest Revision May 22, 2006: 02
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-apps/horde-imp <= 3.2.4 >= 3.2.5 All supported architectures

Related bugreports: #59336

Synopsis

An input validation vulnerability has been discovered in Horde-IMP. This only affects users of Internet Explorer.

2.  Impact Information

Background

Horde-IMP is the Internet Messaging Program. It is written in PHP and provides webmail access to IMAP and POP3 accounts.

Description

Horde-IMP fails to properly sanitize email messages that contain malicious HTML or script code so that it is not safe for users of Internet Explorer when using the inline MIME viewer for HTML messages.

Impact

By enticing a user to read a specially crafted e-mail, an attacker can execute arbitrary scripts running in the context of the victim's browser. This could lead to a compromise of the user's webmail account, cookie theft, etc.

3.  Resolution Information

Workaround

Do not use Internet Explorer to access Horde-IMP.

Resolution

All Horde-IMP users should upgrade to the latest stable version:

Code Listing 3.1: Resolution

# emerge sync

# emerge -pv ">=www-apps/horde-imp-3.2.5"
# emerge ">=www-apps/horde-imp-3.2.5"

4.  References



Print

Page updated August 10, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.