Gentoo Logo

zlib: Denial of service vulnerability

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200408-26 / zlib
Release Date August 27, 2004
Latest Revision May 22, 2006: 02
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
sys-libs/zlib <= 1.2.1-r2 >= 1.2.1-r3 All supported architectures

Related bugreports: #61749

Synopsis

The zlib library contains a Denial of Service vulnerability.

2.  Impact Information

Background

zlib is a general-purpose data-compression library.

Description

zlib contains a bug in the handling of errors in the "inflate()" and "inflateBack()" functions.

Impact

An attacker could exploit this vulnerability to launch a Denial of Service attack on any application using the zlib library.

3.  Resolution Information

Workaround

There is no known workaround at this time. All users are encouraged to upgrade to the latest available version of zlib.

Resolution

All zlib users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge sync

# emerge -pv ">=sys-libs/zlib-1.2.1-r3"
# emerge ">=sys-libs/zlib-1.2.1-r3"

You should also run revdep-rebuild to rebuild any packages that depend on older versions of zlib :

Code Listing 3.2: Resolution

# revdep-rebuild

4.  References



Print

Page updated August 27, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.