Gentoo Logo

PuTTY: Pre-authentication buffer overflow


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200410-29 / putty
Release Date October 27, 2004
Latest Revision May 22, 2006: 02
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-misc/putty <= 0.55 >= 0.56 All supported architectures

Related bugreports: #69123


PuTTY contains a vulnerability allowing an SSH server to execute arbitrary code on the connecting client.

2.  Impact Information


PuTTY is a free implementation of Telnet and SSH for Win32 and Unix platforms, along with an xterm terminal emulator.


PuTTY fails to do proper bounds checking on SSH2_MSG_DEBUG packets. The "stringlen" parameter value is incorrectly checked due to signedness issues. Note that this vulnerability is similar to the one described in GLSA 200408-04 but not the same.


When PuTTY connects to a server using the SSH2 protocol, an attacker may be able to send specially crafted packets to the client, resulting in the execution of arbitrary code with the permissions of the user running PuTTY. Note that this is possible during the authentication process but before host key verification.

3.  Resolution Information


There is no known workaround at this time.


All PuTTY users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/putty-0.56"

4.  References


Page updated October 27, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.