Gentoo Logo

Cherokee: Format string vulnerability

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200411-02 / cherokee
Release Date November 01, 2004
Latest Revision May 22, 2006: 02
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-servers/cherokee <= 0.4.17 >= 0.4.17.1 All supported architectures

Related bugreports: #67667

Synopsis

Cherokee contains a format string vulnerability that could lead to denial of service or the execution of arbitary code.

2.  Impact Information

Background

Cherokee is an extra-light web server.

Description

Florian Schilhabel from the Gentoo Linux Security Audit Team found a format string vulnerability in the cherokee_logger_ncsa_write_string() function.

Impact

Using a specially crafted URL when authenticating via auth_pam, a malicious user may be able to crash the server or execute arbitrary code on the target machine with permissions of the user running Cherokee.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Cherokee users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-servers/cherokee-0.4.17.1"

4.  References



Print

Page updated November 01, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.