Gentoo Logo

Apache 1.3: Buffer overflow vulnerability in mod_include


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200411-03 / apache
Release Date November 02, 2004
Latest Revision December 30, 2007: 02
Impact normal
Exploitable local
Package Vulnerable versions Unaffected versions Architecture(s)
www-servers/apache < 1.3.32-r1 >= 1.3.32-r1 All supported architectures

Related bugreports: #68564


A buffer overflow vulnerability exists in mod_include which could possibly allow a local attacker to gain escalated privileges.

2.  Impact Information


The Apache HTTP server is one of the most popular web servers on the internet. mod_include is an Apache module to handle Server Side Includes (SSI).


A possible buffer overflow exists in the get_tag() function of mod_include.c.


If Server Side Includes (SSI) are enabled, a local attacker may be able to run arbitrary code with the rights of an httpd child process by making use of a specially-crafted document with malformed SSI.

3.  Resolution Information


There is no known workaround at this time.


All Apache users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-servers/apache-1.3.32-r1"

4.  References


Page updated November 02, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.