Gentoo Logo

ProZilla: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200411-31 / ProZilla
Release Date November 23, 2004
Latest Revision May 22, 2006: 03
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-client/prozilla <= 1.3.7.3 All supported architectures

Related bugreports: #70090

Synopsis

ProZilla contains several buffer overflow vulnerabilities that can be exploited by a malicious server to execute arbitrary code with the rights of the user running ProZilla.

2.  Impact Information

Background

ProZilla is a download accelerator for Linux.

Description

ProZilla contains several exploitable buffer overflows in the code handling the network protocols.

Impact

A remote attacker could setup a malicious server and entice a user to retrieve files from that server using ProZilla. This could lead to the execution of arbitrary code with the rights of the user running ProZilla.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

Currently, there is no released version of ProZilla that contains a fix for these issues. The original author did not respond to our queries, the code contains several other problems and more secure alternatives exist. Therefore, the ProZilla package has been hard-masked prior to complete removal from Portage, and current users are advised to unmerge the package.

4.  References



Print

Page updated November 23, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.