Gentoo Logo

Cyrus IMAP Server: Multiple remote vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200411-34 / cyrus-imapd
Release Date November 25, 2004
Latest Revision November 25, 2004: 01
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-mail/cyrus-imapd < 2.2.10 >= 2.2.10 All supported architectures

Related bugreports: #72194

Synopsis

The Cyrus IMAP Server contains multiple vulnerabilities which could lead to remote execution of arbitrary code.

2.  Impact Information

Background

The Cyrus IMAP Server is an efficient, highly-scalable IMAP e-mail server.

Description

Multiple vulnerabilities have been discovered in the argument parsers of the 'partial' and 'fetch' commands of the Cyrus IMAP Server (CAN-2004-1012, CAN-2004-1013). There are also buffer overflows in the 'imap magic plus' code that are vulnerable to exploitation as well (CAN-2004-1011, CAN-2004-1015).

Impact

An attacker can exploit these vulnerabilities to execute arbitrary code with the rights of the user running the Cyrus IMAP Server.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Cyrus-IMAP Server users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-mail/cyrus-imapd-2.2.10"

4.  References



Print

Page updated November 25, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.