Gentoo Logo

Xpdf, GPdf: New integer overflows

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200412-24 / Xpdf
Release Date December 28, 2004
Latest Revision December 28, 2004: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
app-text/xpdf <= 3.00-r6 >= 3.00-r7 All supported architectures
app-text/gpdf <= 2.8.1 >= 2.8.1-r1 All supported architectures

Related bugreports: #75191, #75201

Synopsis

New integer overflows were discovered in Xpdf, potentially resulting in the execution of arbitrary code. GPdf includes Xpdf code and therefore is vulnerable to the same issues.

2.  Impact Information

Background

Xpdf is an open source viewer for Portable Document Format (PDF) files. GPdf is a Gnome-based PDF viewer that includes some Xpdf code.

Description

A new integer overflow issue was discovered in Xpdf's Gfx::doImage() function.

Impact

An attacker could entice an user to open a specially-crafted PDF file, potentially resulting in execution of arbitrary code with the rights of the user running Xpdf or GPdf.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Xpdf users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/xpdf-3.00-r7"

All GPdf users should also upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/gpdf-2.8.1-r1"

4.  References



Print

Page updated December 28, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.