Gentoo Logo

TikiWiki: Arbitrary command execution

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200501-12 / tikiwiki
Release Date January 10, 2005
Latest Revision May 22, 2006: 03
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-apps/tikiwiki < 1.8.4.1 >= 1.8.4.1 All supported architectures

Related bugreports: #75568

Synopsis

A bug in TikiWiki allows certain users to upload and execute malicious PHP scripts.

2.  Impact Information

Background

TikiWiki is a web-based groupware and content management system (CMS), using PHP, ADOdb and Smarty.

Description

TikiWiki lacks a check on uploaded images in the Wiki edit page.

Impact

A malicious user could run arbitrary commands on the server by uploading and calling a PHP script.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All TikiWiki users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/tikiwiki-1.8.4.1"

Note: Users with the vhosts USE flag set should manually use webapp-config to finalize the update.

4.  References



Print

Page updated January 10, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.