Gentoo Logo

Newspost: Buffer overflow vulnerability

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200502-05 / newspost
Release Date February 03, 2005
Latest Revision February 21, 2005: 02
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-nntp/newspost < 2.1.1-r1 revision >= 2.0-r1, >= 2.1.1-r1 All supported architectures

Related bugreports: #78530

Synopsis

A buffer overflow can be exploited to crash Newspost remotely and potentially execute arbitrary code.

2.  Impact Information

Background

Newspost is a Usenet News binary autoposter.

Description

Niels Heinen has discovered a buffer overflow in the socket_getline() function of Newspost, which can be triggered by providing long strings that do not end with a newline character.

Impact

A remote attacker could setup a malicious NNTP server and entice a Newspost user to post to it, leading to the crash of the Newspost process and potentially the execution of arbitrary code with the rights of the Newspost user.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Newspost users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-nntp/newspost-2.0-r1"

4.  References



Print

Page updated February 03, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.